EBGP Peering
Topology.gambar 1.1
sebelumnya lab ini adalah lanjutan dari lab yang sebelumnya jadi di materi yang ketiga yang akan kita config masih nyambung dengan lab sebelumnya yaitu (lab konfig dasar IBGP Peering, IBGP Peering loopback).
Konfigurasi dulu ip address nya
R2(config)#int s1/0
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#
R2(config-if)#router bgp 12
R2(config-router)#neighbor 23.23.23.3 remote-as 3
R2(config-router)#
R3(config)#int s1/0
R3(config-if)#ip add 23.23.23.3 255.255.255.0
R3(config-if)#no shut
R3(config)#router bgp 3
R3(config-router)#neighbor 23.23.23.2 remote-as 12
R3(config-router)#net 3.3.3.3 mask 255.255.255.255
R3(config-router)#
Sebelumnya cek bgp peersnya
R3(config-router)#do sh ip bgp sum
BGP router identifier 3.3.3.3, local AS number 3
BGP table version is 4, main routing table version 4
3 network entries using 432 bytes of memory
3 path entries using 240 bytes of memory
3/3 BGP path/bestpath attribute entries using 432 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1128 total bytes of memory
BGP activity 3/0 prefixes, 3/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
23.23.23.2 4 12 6 5 2 0 0 00:00:05 2
nah disini sudah ada 2 route
Selanjutnya lakukan test ping
R3#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Wah ternyata 0 percent berarti tidak bisa di ping ,cek di sisi router R1
R1(config-router)#do sh ip bgp
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
* i 3.3.3.3/32 23.23.23.3 0 100 0 3 i
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i 22.22.22.22/32 2.2.2.2 0 100 0 i
R1(config-router)#
Terlihat bahawasanya route bgp dari R3(3.3.3.3) tidak ada tanda > best nya .hal tersebut dikarenakan ip next hoop nya tidak reachable dari R1.yang menyebabkan ketika paket dikirim dan sampai ke R1, R1 tidak tau untuk mengembalikan paket icmp tersebut ke R3.
Cek routing table router R1
R1#sh ip route
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
R 2.0.0.0/8 [120/1] via 12.12.12.2, 00:00:01, Serial5/0
11.0.0.0/32 is subnetted, 1 subnets
C 11.11.11.11 is directly connected, Loopback1
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Serial5/0
L 12.12.12.1/32 is directly connected, Serial5/0
22.0.0.0/32 is subnetted, 1 subnets
B 22.22.22.22 [200/0] via 2.2.2.2, 00:46:06
R1#
Walah tidak satupun route yang berasal dari R3 baik itu interface loopback maupun physicalnya .terutama ip 23.23.23.3 yang menjadi next hop menuju ke 3.3.3.3
Nahh sebenernya ada beberapa cara yang bisa dilakukan,salah satunya adalah mengadvertise network 23.23.23.0 ke bgp pada R2
R2(config-router)#router bgp 12
R2(config-router)#network 23.23.23.0 mask 255.255.255.0
R2(config-router)#
Cek kembali di sisi R1
R1#sh ip bgp
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
*>i 3.3.3.3/32 23.23.23.3 0 100 0 3 i
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i 22.22.22.22/32 2.2.2.2 0 100 0 i
*>i 23.23.23.0/24 2.2.2.2 0 100 0 i
R1#
Nahh sekarang terlihat route 23.23.23.0 serta pada route 3.3.3.3 sudah muncul tanda > best yang dikarenakan next hoop nya sudah reachable.
Selanjutnya lakukan test ping kembali dari R3
R3#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/60/88 ms
R3#
Yuuhhhuuyyy hasilnya reply …….sekarang bagaimana kalo ping dari R1
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#
Anjirr ternyata RTO..selanjutnya coba kita gunakan source yang ip nya sudah diketahui R3 ,cek dulu ip nya R1 yang di kenali oleh R3 apa aja
R3#sh ip route
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
11.0.0.0/32 is subnetted, 1 subnets
B 11.11.11.11 [20/0] via 23.23.23.2, 01:07:53
22.0.0.0/32 is subnetted, 1 subnets
B 22.22.22.22 [20/0] via 23.23.23.2, 01:07:53
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, FastEthernet3/0
L 23.23.23.3/32 is directly connected, FastEthernet3/0
R3#
Ternyata hanya ip 11.11.11.11 yang dikenali maka gunakan sebagai sourcenya
R1#ping 3.3.3.3 source 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 11.11.11.11
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/59/92 ms
R1#
Yups reply, pada ping sebelumnya RTO karena, ketika tidak menambahkan source nya, maka yang digunakan sebagai source adalah ip physicalnya yakni 12.12.12.1 yang mana tidak ada dalam routing tabelnya Router R3.
Jika diinginkan tanpa menggunakan source. Cara yang sama bisa dilakukan yakni mengadvertise network 12.12.12.0 ke BGP pada Router R1 sehingga dapat dikenali oleh Router R3
R2(config-router)#router bgp 12
R2(config-router)#network 23.23.23.0 mask 255.255.255.0
Setelah itu cek di R3 terlebih dahulu,pastikan network 12.12.12.0 sudah dikenali
R3#sh ip route
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
11.0.0.0/32 is subnetted, 1 subnets
B 11.11.11.11 [20/0] via 23.23.23.2, 01:19:37
12.0.0.0/24 is subnetted, 1 subnets
B 12.12.12.0 [20/0] via 23.23.23.2, 00:00:16
22.0.0.0/32 is subnetted, 1 subnets
B 22.22.22.22 [20/0] via 23.23.23.2, 01:19:37
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, FastEthernet3/0
L 23.23.23.3/32 is directly connected, FastEthernet3/0
R3#
Lakukan testing lagi dari R1 tanpa menggunakan source
R1(config-router)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/34/56 ms
R1(config-router)#
Mantulll kuyyy hasilnya reply